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These slides are part of the Topic 2 on “Basic digital skills

and tools” of the course on Digital skills in Textile and
clothing industry.

Check also the other themes in this topic:
e 2.1. Text formatting
e 2.2. Electronic tables
* 2.3. Working with presentations
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1. Introduction to the Usage of Macros

 The Basics of Macros

* Macros in Microsoft Word and Excel
— Activation of Macros

— Creation of Macros

— Use of Macros
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* |n the three other themes in this topic, we used the free online
Office application.

* Working with Macros is not available in the free online
Microsoft Office application.

* You may need to use the desktop application to create and edit
Macros.
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The Basics of the Macros

* Macros are tools that are used by users when there is a
repeatability of the same actions.

* In such a situation, users in Microsoft Word and Excel often
have to do and repeat the same actions.

* These repetitive actions such as repeated data entry,
formatting and styling text and many other actions can be

automated by Macros.
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The Basics of the Macros

* Macros represent a created (and recorded by users) series of
consistent steps of instructions that Microsoft Word/Excel
must automatically execute at the user's desire.

e Users can create Macros and use them when they need to by
pressing a personalized button or a preset key combination on
the keyboard (set by the users).

e Therefore Macros save a lot of time and effort in the users'
work.
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The Basics of the Macros

e To use Macros in Microsoft is necessary to pre-allow the
application to use these tools.

* For this reason, if you give access to the use of Macros, you will
also allow access to your operating system.

* Therefore it carries significant risks to the security of your system.

* You should use the Macros very carefully and only from trusted
sources, as they may contain various harmful viruses to damage
your system and compromise your data and security.
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Macros in Microsoft Word and Excel
Activation of Macros

* Macros are one of the developer features.

— By default, the developer tools are not displayed in Microsoft Word
and Excel

— You will need to display the developer tools via Options dialog menu.

— After that the Macros menu will be visualized in the main panel and
ready to use.

2.4. Working with macros Back to Contents ICT-TEX course on Digital skills 9
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Macros in Microsoft Word and Excel
Activation of Macros

i -
* Enabling developer
featu res File Home Insert Page Layout Formulas Data Review  View
I .". % Cut Calibri 11 - A
— First you must open your B g Copy - - A
. aste » e B I U -~ ) ) 5
document flle (Word or ~ ' Format Painter 2
Clipboard = Font
excel)

-

— To enable and display the
developer features, you first
go to the main menu “FILE”
and click it.
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> MNew blank rkb

Activation of Macros E

* Enabling developer
features
— Next, a menu will open.

— You select “Options”
(underlined in red oval)
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* Enabling developer features = | R
— Next, the “Excel Options” menu - . :

Main Tabs

i Save d or ove Filters
W I a p p e a r O n s C re e n . es... [Create Cha & M Background Removal
anguage »
LJ oar

— You select “Customize Ribbon”
(underlined in red oval on the

left)

— Then, you have to check the
“Developer” tab to be displayed
on the “Customize the Ribbon”
tab (underlined in red oval on the
right).

— Click “OK” to finish the process.
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Macros in Microsoft Word and Excel
Activation of Macros

° =
o
File Home  Insert  Page Layout Formulas Data  Review View | Developer = Office Tab  Help Q Tell me what you want to do

.i r gH Record Macro i B Properties Ia = ﬁ‘ Import
; L f8 Use Relative References Lo 1w o view Code == [&] expansion Packs [
Visual Macros Add- bxcel COM nse| Source "

Basic A\ Macro Security ins  Add-ins Add-ins v Run Dialog &

Code Add-ins Controls XML

— Now the “Developer tab”
will be displayed.

— Now you can create, use

and customize the Macros
in Microsoft Word and '
Excel. View of Developer tab in Microsoft Excel 2019

2.4. Working with macros | Back to Contents ‘ ICT-TEX course on Digital skills 13



Co-funded by the
Erasmus+ Programme
of the European Union

Macros in Microsoft Word and Excel
Activation of Macros

(e ) SOFIA UNIVERSITY
v/ “ST, KLIMENT OHRIDSKI -

EST. 1888

File Home  Insert  Page layout Formulas Data Review View | Developer | Office Tab Help Q Tell me what you want to do

.-&\. g8 Record Macro o d B Properties IE Ere E¥ Import
& Ew O =

“% & Use Relative References o e S8 View Code Expansion Packs &
Visual Macros Add- Excel COM Insert N Source iﬂ ;

Basic A Macro Security ins  Add-ins Add-ins & Run Dialog
Code Add-ins Controls

f New Microsoft Excel Worksheet.xlsx

View of Developer tab in Microsoft Word 2019
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Macros in Microsoft Word and Excel
Activation of Macros

* Enabling Macros

— When trying to run Macros on S
Microsoft Word and Excel you File Home Insert Draw Design Layout References Mailings Review View Help Q Tell me what you w4
have to enable Macros to run in i LnuxBiolium  ~|[17 | A A | Aa~ | 2 !
the application. e | B S WA ce.m- DO

Clipboard ~ ¥ Paragraph

— You can do that by pressing the
“Enable Content” box presented
in the Message bar to enable
Macros.

— By default Macros are disabled
concerning the various security
risks.

Enable Content

2.4. Working with macros Back to Contents ICT-TEX course on Digital skills 15
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Act I Va t I O I l Of IVI a C ro S eeeee O Help keep your documents safe and your computer secure and healthy.
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Security & more

* Enabling Macros
— The "Macros Settings" =
menu is another way to

enable or disable Macros dqe e
in the application globally.

— First, click the “FILE” tab.
— Click “Trust Center”

— Click the “Trust Center
Settings”

Microsoft Word Trust Center

The Trust Center contains security and privacy settings. These settings help keep your computer
ecure. We recommend that you do not change these settings.
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Trusted Publishers
Trusted Locations
T

rusted Documents )
Disable all ma

* Enabling Macros

Add-ins nable all macros (not recommended; potentially dangerous code can run)

ActiveX Settings

— Select the “Macro o
Settings”

— Now the “Macro Settings”
menu will be visualized.

— Here you can adjust the
settings for Macros by
disabling or enabling
them.

Protected View
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* Enabling Macros

— You can also enable Macros security settings by the Developer tab (if you
have enabled the Developer tab). Click on the “Macro Security”.

— This will open the “Macro Settings” menu, described in the previous slides.
=

File Home Insert Draw  Design Layout  References Mailings Review View  Developer Help Q Tell me what you want to do

ﬁ 'i @l Record Macro ﬁ? = Aa Az B8 Eg LI Design Mode 'Ei VEJ

: Bi BEE B . ;
Visual Macros _ Add- Word COM _ = XML Mapping Restrict Document
Basic A\ Macro Security ins Add-ins Add-ins Bw &7 ~ Pane Editing Template

Code Add-ins Controls Mapping Protect Templates
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Macros in Microsoft Word and Excel
Creation of Macros

* The creation of Macros in Microsoft Word and Excel is done in an easy and
convenient way.

* When the user wants to create Macros to automate a particular activity as
a sequence of steps, he/she must pre -record these steps as he personally
makes them in the application.

* During the entry, the application will record any activity that the user
made.

* When these steps are completed, the use must stop the recording.

* As aresult, a new Macro will be available that can be reused repeatedly by
users.

2.4. Working with macros I Back to Contents ‘ ICT-TEX course on Digital skills 19
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Macros in Microsoft Word and Excel
Creation of Macros

* Users can access Macros in two ways
— Using the “Developer tab” enabled as explained in previous slides.
— Using the “Macros menu” located in the “View” tab.

2.4. Working with macros Back to Contents ICT-TEX course on Digital skills 20
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Creation of Macros

* Users can access Macros in two ways
— Macros menu in the “View” tab in Microsoft Excel 2019

New Microsoft Excel Worksheetxlsx - Excel

=

File Home Insert  Page Layout Formulas Data Review | View | Developer OfficeTab  Help

- E . . v Formula Bar [.1 —_- = g B Split :;

Q Tell me what you want to do

M| Hide : 3

Zoom 100% Zoom to New Arrange Freeze _ Switch Macros
Selection Window All Panes v Bid Windows ~ "

Window Macros

Normal Page Break Page Custom [ coqinac [ Headings
Preview Layout Views

Workbook Views Show

| : Je

Zoom
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Creation of Macros

* Users can access Macros in two ways
— Macros menu in the “View” tab in Microsoft Word 2019

Document1 - Word

(™

File Home Insert Draw Design Layout References Mailings Review | View | Developer Help

g B Outline ' l v/ Ruler t = B il ] F
. . ""‘ Bl = .. —- — . . = 'j s

Q Tell me what you want to do

8 Draft Gridlines BE Multiple Pages 1B ] :
New Arrange Split Switch Macros  Properties

Read Print Web Immersive  Switch ~ Vertical Side _4 Zoom 100% :
Mode Layout Layout Reader  Modes to Side Navigation Pane B’ Page Width Window Al ul Windows ~ v

Views Immersive  Dark Mode Page Movement Show Zoom Window Macros SharePoint
£ 20 o1 | o1 o0 020 100 1 A1 120 130

L
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Creation of Macros

 The process of creation a Macro starts as follows:
— First select “View Tab” (Microsoft Excel 2019)
— Click the “Macros tab”
— Click the “Record a Macro”

New Microsoft Excel Worksheetxlsx - Excel

=

File Home  Insert Page Layout = Formulas Data Review | View | Developer  Office Tab Help

Q Tell me what you want to do

A ! i 17
. . +| Formula Bar i m" = - M Split -
- ™ Hide B

100% Zoom to MNew Arrange Freeze
Selecion ~Window All Panes ~

_ Macros
Windows ~ =

Window FR View Macros

B Record Macro..

Normal Page Break Page Custom | Gridlines [v] Headings
Preview Layout Views

Workbook Views Show

2 Use Relative References

g New Microsoft Excel Worksheet.xlsx
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Macros in Microsoft Word and Excel
Creation of Macros

* After completing the steps a new
menu will open with the B

ICT-TEX

following features: el —
 The user can set the “Macro name” e Macrof|

* Can assign a key-combination on i
the keyboard for activating/stoping

Ctrl+

Store macro in:

a recording of a Macro e
* A place to store the new Macro ’ e

* Ashort text description of the new
Macro

* If everything is set, the user has to
L

click “OK” to start the recording

Cancel

2.4. Working with macros I Back to Contents ICT-TEX course on Digital skills
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Macros in Microsoft Word and Excel
Creation of Macros

* After clicking “OK”, the
Recording of a Macro starts

Record Macro

* This means that every
action that is made by the
user is being recorded for
automatization and for the
creation of the Macro.
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Macros in Microsoft Word and Excel

Creation of Macros

 When the user wants to stop the recording, that can be done by two ways:

— With the preset key-combination
— Or by clicking the “Stop Recording” in “Macros” menu on the “View tab”

New Microsoft Excel Worksheetxlsx - Excel

=

File Home  Insert  Page layout Formulas  Data Review | View | Developer  Office Tab Help

Q Tell me what you want to do

| 3 X : -
. : . = | Formula Bar [ ; mt N - &= Split il =
I ' o m R T muee B =i ER
Zoom 100% Zoom to New Arrange Freeze Switch Macros

Selection Window All  Panes ~ Windows ~
Window F&  View Macros

Normal Page Break Page Custom 7 chidlines [ Headings
Preview Layout Views

Workbook Views
Stop Recording

iE Use Relative References

B New Microsoft Excel Worksheet.xlsx
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e After the recording is stopped the new Macro is saved for future use.

 The user can access it and run it (activate Macro) from the “Macros” menu by:
— By clicking the preset key-combination on the keyboard (bind for the desired and created Macro).
— By clicking the “View Macros” and selecting the Macro and run it.

= = New Microsoft Excel Worksheetxlsx - Excel
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File Home Insert  Pagelayout Formulas Data Review | View | Developer OfficeTab  Help Q Tell me what you want to do

S " BN
. . ~| Formula Bar - -
= [ | -

Mormal Page Break Page Custom | Gridlines v] Headings Zoom 100% Zoom to MNew Arrange Freeze

== Split [ ]}

8 Hide HE}
Switch Macros

Preview Layout Views Selection ~Window All  Panes ~ bl Windows ~ =

Workbook Views Show Zoom Window Ex View Macros
B Record Macro..

%2 Use Relative References
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Macros in Microsoft Word and Excel
Creation of Macros

* For example, a user can make a Macro for creating a simple
table in Microsoft Excel 2019.

* The user starts the recording of a Macro.

* Then, the user creates a table and applies the desired styles and
formatting.

e After finishing the table, the user stops the recording, and the
Macro is saved in the application for future use.
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Macros in Microsoft Word and Excel

Use of Macros
* To view the Macros, the user opens tel\/lacrs menu.

SOFIA UNIVERSITY
& “ST. KLIMENT OHRIDSKI -

Home Insert Page Layout Formulas Data Review View Developer Office Tab Help Q Tell me what you want to do

-
=
—

Arran e | cl acro name:
All i

Zoom

L9 - i fe

i New Microsoft Excel Worksheet.xlsx *

A B C D E = e Q
1 |Columnl B Column2 i Column3 f Column4 i Column5 B Columné g Column? —
Macros in: | All Open Workbooks b
A Descri ption
_ Ca

—
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Macros in Microsoft Word and Excel

Use of Macros
* In the “Macro” menu, the

user Can. oo e i
— View the created Macros with e il
their names and select one of et
them by clicking on its name. -}
— Delete a created Macro _ |
— Adjust the options of the vacros | alopen orioot .
Macros
— Edit the created Macro.
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* |nthe “Macro” menu, the user can:
— To adjust the setting of the created Macro, the user has to click “Options”.

— On the “Macro Options” menu, the user can assign a key-combination on the keyboard for the Macro
(assigned as “CTR + “), and add a text description of the Macro.

Macro name: =4
Macro4 o | I Mg _
[ Bun o Macro Options
Mrlacrol ros Mg
Mg
Mlacro Step Into ol Macro name: N
Az Mlacrod I
Edit £
Shortcut key: W
Create ctrl+ || i
" Description: I ]
I Delete I C — = i —
I Options... I | :I |
. M
rAacros in: All Open Workbooks b
S Des
Description Ok I Cancel

Cancel
Cancel
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Use of Macros

“@ Microsoft Visual Basic for Applications

In the “Macro” menu,
the user can:

e To edit the created
Macro, the user has
to click “Edit”.

* |t opens a Microsoft
Visual Basic for
Application editor.

* On this editor, the
user can observe and
edit the generated
code of the created
Macro.

2.4. Working with macros
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Project - VBAProject

File Edit View Insert Format Debug Run Tools Add-Ins Window Help
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ICT-TEX

=423 Microsoft Excel Objects
EH] Sheet2 (Sheett)
@ Thisworkbook
(=455 Modules
3 Modulel

~

Properties - Sheet2

=88 vBAProject (lew Microsoft Excel Workshe:

v s K EFE @ | 1n23,Coln =
X
i % New Microsoft Excel Worksheetxlsx - Module1 (Code) E@
[(General) | [Macros “]
—
~

Sub Macrod ()

' Macrod4 Macro
'

Range ("R1:G10").select
Application.CutCopyMode = False

"Table5"
Range ("Table5[#A111") .Select
Selection.Borders (x1DiagonalDown) .LineStyle = xlNone
Selection.Borders (x1DiagonalUp) .LineStyle = xlNone
with Selection.Borders (xlEdgeLeft)
.LineStyle = xlContinuous
.Color = -1€6776961
.TintAndShade = 0
.Weight = x1Thick
End With
E With Selection.Borders (x1EdgeTop)
.LineStyle = xlContinuous

Sheet2 Worksheet

.Color = -16776961

Alphabetic categorized

-TintAndShade = 0

(Name) Sheet2
DisplayPageBreaks False
DisplayRightToLeft False
False
EnableCalculation True
onditionsCalc True
EnableQutlining False
Table False
0 - xNoRestrictions
Mame Sheetl
ScrollArea
StandardWwidth 8.11
Visible -1 - xISheetVisible

.Weight = x1Thick

End With

With Selection.Borders (x1EdgeBottom)
.LineStyle = xlContinuous
.Color = -16776961
.TintAndShade = 0
.Weight = x1Thick

End With

with Selection.Borders (x1EdgeRight)
.LineStyle = xlContinuous
.Color = -1677€961
.TintAndShade = 0
.Weight = x1Thick

End With

ActiveSheet.ListObjects.Add (x1SrcRange, Range ("SAS1:3G510™), ,

x1No) .Name = _

I Back to Contents
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Macros in Microsoft Word and Excel

Use of Macros

* To save the created Macros in Microsoft Excel 2019, the user
has to save the document (entire excel workbook) in a Excel
Macro-enabled format (*.xIsm).

- Local Disk (D:)

File name: | New Microsoft Excel Worksheet.xlsx

Save as type: | Excel Workbook (*xlsx)

Excel Workboo (lsx)

» Hide Folders

2.4. Working with macros I Back to Contents ICT-TEX course on Digital skills 33
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Macros in Microsoft Word and Excel

Use of Macros

* To save the created Macros in Microsoft Word 2019, the user
has to save the document in a Word Macro-enabled format
(*.docm).

File name: | Doc4.docx

Save as type: |Word Document (*.docx)

~ Hide Folders
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